Warning: Illegal string offset 'html' in /home/nissansi/public_html/forums/cache/skin_cache/cacheid_1/skin_topic.php on line 907
Need help! Evo 8mr - Hardtuned.net

Jump to content


Need help! Evo 8mr 

  • You cannot reply to this topic
No replies to this topic

#1 Koukikelvin

  • Joined:17-May 14
  • Location:Australia NSW
  • Car:S15

Posted 07 June 2014 - 09:19 AM

Hi people, new member here, if I could get anyone's opinion and advice it would greatly be appreciated. My evo is blowing a lot of constant thick white smoke. All started happening after the other night, I was driving home from work and hit something that had pierce a hole in the intercooler about the size of a 20c piece, it was also raining pretty heavy too. Decided to garage it for the week and use the s15 till I got another intercooler. Started the evo yesterday and it's fine for the first 20-30 seconds then just starts blowing white smoke. My oil isn't milky or anything and the radiator coolant is fine. Any opinions would be great, thanks!

Kelvin





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Common Links

  • About Us
  • Privacy Policy
  • User Agreement
  • Help & Support Forums
  • Advertise
  •  

    By your continued use of this site, you agree to follow all Rules & Guidelines and abide by the User Agreement outlined in our Terms & Conditions.

    Hardtuned Network is hosted by Sanity Technology

    Design, Site Management & Hotness provided by Loz.

    Big thanks to all our members and volunteers for making this network what it is today!