Warning: Illegal string offset 'html' in /home/nissansi/public_html/forums/cache/skin_cache/cacheid_1/skin_topic.php on line 907
mates supra - Hardtuned.net

Jump to content


mates supra 

supra backfire engine
6 replies to this topic

#1 Daniel Ostrovskih

  • Joined:10-February 12

Posted 06 March 2012 - 05:50 PM

hey guys, my friend bought a supra today and it was working fine on the drive back to my mates house, but after the car was sitting there for about an hour, there was something wrong with the engine.. either the engine or the clutch or gear...

the problem is pretty much the car backfires before it even reaches the redline of the car so it pretty much backfires around 3-5k rpms, not only that but when you flat foot it it doesnt accelerate at all.. any ideas ?

#2 EnFlaMEd

  • Joined:06-January 05
  • Location:Australia SA

Posted 06 March 2012 - 05:54 PM

What model Supra? What engine? What modifications does it have?

#3 Daniel Ostrovskih

  • Joined:10-February 12

Posted 06 March 2012 - 05:58 PM

to be honest, it has no mods expect a really badly installed pod, the pod is just hanging on the side of the engine with no piping... also all i know about the engine is its non turbo..... sorry guys dont know much about supras is there different types of non turbo supras or ? i feel bad for the kid, the car was fine until he got home and now the car is driving like a slug

#4 EnFlaMEd

  • Joined:06-January 05
  • Location:Australia SA

Posted 06 March 2012 - 06:06 PM

View PostDaniel Ostrovskih, on 06 March 2012 - 05:58 PM, said:

to be honest, it has no mods expect a really badly installed pod, the pod is just hanging on the side of the engine with no piping... also all i know about the engine is its non turbo..... sorry guys dont know much about supras is there different types of non turbo supras or ? i feel bad for the kid, the car was fine until he got home and now the car is driving like a slug

Yes there are many different types of non turbo supras. Do you know what year it is? That would at least narrow it down a bit.

#5 Daniel Ostrovskih

  • Joined:10-February 12

Posted 06 March 2012 - 06:08 PM

its a 94 JZA supra engine

Edited by Daniel Ostrovskih, 06 March 2012 - 06:13 PM.


#6 EnFlaMEd

  • Joined:06-January 05
  • Location:Australia SA

Posted 06 March 2012 - 06:25 PM

Ok so 2jz-ge motor. Do you know if the engine check light has come on at all?

Is it running bad all of the time now or only when its warmed up?

#7 Daniel Ostrovskih

  • Joined:10-February 12

Posted 06 March 2012 - 06:27 PM

no light comes up, and its all the time, he got it from essedon and bought it back to dandy so it was like a 1-2 hour drive and the car was fine, but after turned the car off for about an hour then when he drove it again it started backfiring for no reason and if you flat foot it it doesnt even accelerate





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Common Links

  • About Us
  • Privacy Policy
  • User Agreement
  • Help & Support Forums
  • Advertise
  •  

    By your continued use of this site, you agree to follow all Rules & Guidelines and abide by the User Agreement outlined in our Terms & Conditions.

    Hardtuned Network is hosted by Sanity Technology

    Design, Site Management & Hotness provided by Loz.

    Big thanks to all our members and volunteers for making this network what it is today!